Viking Flush Mount Handsfree Entry Phone with Enhanced Weather Protection

(Model # E-30-EWP)
Viking Flush Mount Handsfree Entry Phone with Enhanced Weather Protection
Viking
Operating Temperature: -26C to 54C (-15F to 130F)

Note: Picture may not represent the actual product. We are continuously working on improving our website and reserve the right to change specifications, availability, and pricing without prior notice.

  • $339.86

  • Availability:
  • In Stock
  • Manufacturer
  • 2 Year Limited Warranty
Qty:
E-30-EWP Flush Mount Handsfree Entry Phone with Built-In Auto Dialer and Enhanced Weather Protection is designed to provide quick and reliable handsfree communication and can be connected directly to a C.O. line or analog PABX/KSU station.
Entry Phone with Dialer Features:
  • Built-In Auto Dialer
  • Enhanced Weather Protection
  • Handsfree operation
  • Phone line powered
  • Vandal resistant, stainless steel faceplate with heavy duty metal call button
  • Non-volatile E2 memory (no batteries required)
  • Touch tone or pulse dialing
  • Programmable to dial up to 5 numbers on busy or ring no answer
  • Red LED off-hook indicator
  • Hangs up on CPC, silence, busy signal, return to dial tone, time out or a touch tone command
  • Programmable to auto-answer on incoming calls
  • Remotely programmable
  • Humidity - E-30-EWP: Up to 100% condensing
  • Weather resistant
  • Rough in box included
  • E-30-EWP is designed to meet IP66 Ingress Protection Rating
  • Enhanced weather protection (EWP) option ideal for outdoor or harsh environments
  • UPC Code: 677721972970
  • GTIN 0677721972970
Enhanced Weather Protection Option Includes:
  • Rubber gaskets
  • Boots
  • Silicon sealed connections
  • Gel-filled butt connectors
Other Available Models:

    Speakerphone with Enhanced Weather Protection and Push to Talk Button E-30
    Speakerphone with Push To Talk Button E-30-PT
    Speakerphone with Enhanced Weather Protection and Push to Talk Button E-30-PT-EWP
NOTE: Viewing PDF documents requires the free Adobe® Reader® version 5.0 or greater.If you don't already have it installed, you will need to download and install it before using PDF documents.
Get Adobe Reader